Home » MPLS » Basic Frame Mode MPLS Configuration

Basic Frame Mode MPLS Configuration

STEPS:
1. Enable CEF
2. Configure IGP Routing Protocol
3. Configure Label Distribution Protocol (LDP or TDP)
4. Assign LDP Router ID
5. Configure MPLS label Forwarding on the interface

Example

MPLS Configurations

Node LDP Configuration MPLS Forwarding on Interface
Router R1 IP CEF Enabled Provider MPLS R1(config)#mpls label protocol ldp
R1(config)#mpls ldp router-id fa0/0
R1(config)#int fa0/0
R1(config-if)#mpls ip
Router R2 IP CEF Enabled Provider MPLS R2(config)#mpls label protocol ldp
R2(config)#mpls ldp router-id f0/0
R2(config)#int f0/0
R2(config-if)#mpls ip
R2(config)#int fa0/1
R2(config-if)#mpls ip
Router R3 IP CEF Enabled Provider MPLS R3(config)#mpls label protocol ldp
R3(config)#mpls ldp router-id f0/0
R3(config)#int fa0/0
R3(config-if)#mpls ip
R3(config)#int fa1/0
R3(config-if)#mpls ip
Router R4 IP CEF Enabled Provider MPLS R4(config)#mpls label protocol ldp
R4(config)#mpls ldp router-id fa0/0
R4(config)#int fa0/0
R4(config-if)#mpls ip
Router R5 Customer Site-1 Router IP CEF Enabled Customer Side No MPLS Customer Side No MPLS
Router R6 Customer Site-2 Router IP CEF Enabled Customer Side No MPLS Customer Side No MPLS

Other Required Configurations Before Configuring MPLS

Node Interface Config BGP Config OSPF Config LDP Configuration MPLS Forwarding on Interface
Router R1 IP CEF Enabled Provider MPLS interface FastEthernet0/0
description To-R2
ip address 10.1.1.1 255.255.255.252
router bgp 65530
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
redistribute ospf 1
neighbor 10.1.1.10 remote-as 65530
neighbor 10.1.1.10 next-hop-self
neighbor 192.168.11.1 remote-as 65531
no auto-summary
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
redistribute bgp 65530 subnets tag 1111
network 10.0.0.0 0.255.255.255 area 0
R1(config)#mpls label protocol ldp
R1(config)#mpls ldp router-id fa0/0
R1(config)#int fa0/0
R1(config-if)#mpls ip
interface Serial1/0
description To-Customer1-R5
ip address 192.168.11.2 255.255.255.252
encapsulation ppp
Router R2 IP CEF Enabled Provider MPLS interface FastEthernet0/0
description to-R1
ip address 10.1.1.2 255.255.255.252
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.0.0.0 0.255.255.255 area 0
R2(config)#mpls label protocol ldp
R2(config)#mpls ldp router-id f0/0
R2(config)#int f0/0
R2(config-if)#mpls ip
interface FastEthernet0/1
description to-R3
ip address 10.1.1.5 255.255.255.252
R2(config)#int fa0/1
R2(config-if)#mpls ip
Router R3 IP CEF Enabled Provider MPLS interface FastEthernet0/0
description to-R2
ip address 10.1.1.6 255.255.255.252
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 10.0.0.0 0.255.255.255 area 0
R3(config)#mpls label protocol ldp
R3(config)#mpls ldp router-id f0/0
R3(config)#int fa0/0
R3(config-if)#mpls ip
interface FastEthernet1/0
description to-R4
ip address 10.1.1.9 255.255.255.252
R3(config)#int fa1/0
R3(config-if)#mpls ip
Router R4 IP CEF Enabled Provider MPLS interface FastEthernet0/0
description to-R3
ip address 10.1.1.10 255.255.255.252
router bgp 65530
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
redistribute ospf 1
neighbor 10.1.1.1 remote-as 65530
neighbor 10.1.1.1 next-hop-self
neighbor 192.168.12.1 remote-as 65531
no auto-summary
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
redistribute bgp 65530 subnets
network 10.0.0.0 0.255.255.255 area 0
R4(config)#mpls label protocol ldp
R4(config)#mpls ldp router-id fa0/0
R4(config)#int fa0/0
R4(config-if)#mpls ip
interface Serial1/0
description to-cust-R6
ip address 192.168.12.2 255.255.255.252
encapsulation ppp
Router R5 Customer Site-1 Router IP CEF Enabled interface Serial1/0
description to-provider-edge
ip address 192.168.11.1 255.255.255.252
encapsulation ppp
router bgp 65531
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 192.168.11.2 remote-as 65530
no auto-summary
ip route 192.168.11.0 255.255.255.0 null 0    (to have the route in routing table) Customer Side No MPLS Customer Side No MPLS
Router R6 Customer Site-2 Router IP CEF Enabled interface Serial1/0
description to-R4
ip address 192.168.12.1 255.255.255.252
encapsulation ppp
router bgp 65531
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 192.168.12.2 remote-as 65530
no auto-summary
ip route 192.168.12.0 255.255.255.0 null 0 (to have the route in routing table) Customer Side No MPLS Customer Side No MPLS

Verification Commands:

Verify CEF is turned on
1. Show ip cef
2. show ip cef interface

Verify MPLS Forwarding
1. show mpls interfaces

Verify LDP Discovery and neighbors
1. show mpls ldp discovery
2. show mpls ldp neighbor

Verify label assignments and mpls forwarding table
1. show mpls ldp bindings
2. show mpls forwarding-table

Incoming search terms for the article:

Leave a Reply